3 sep. 2006

Reparando apache2 luego de una actualizacion

Hoy domingo, me puse a actualizar los pquetes de mi debian etch, entre todos ellos me toco actualizar apache2, con lo que no conte fue que luego de actualizarlo me iba a aparecer este error:


Asi que me puse a revisar el log y solo veia errores del tipo
[Sun Sep 03 12:07:33 2006] [error] [client ::1] SoftException in Application.cpp:193: Script "/var/www/phpmyadmin/index.php" resolving to "/usr/share/phpmyadmin/index.php" not within configured docroot
[Sun Sep 03 12:07:33 2006] [error] [client ::1] *** glibc detected *** double free or corruption (fasttop): 0x08070ca8 ***
[Sun Sep 03 12:07:35 2006] [error] [client ::1] Premature end of script headers: index.php



Habilite el modulo para php4
PcChristian:~# a2enmod php4
Verifique que la esta linea apareciera en el DirectoryIndex en apache2.conf
DirectoryIndex index.php index.html index.cgi index.pl index.xhtml
verifique que no hubiera ningun cambio en el soporte para mysql en el archivo php.ini para apache2
extension=mysql.so


Y finalmente ya todo esta ok.